- add build option for disabling SELinux support (on rpm >= 4.3)
[apt.git] / apt-pkg / rpm / rpmpm.cc
index efe8116..4d69e75 100644 (file)
@@ -793,7 +793,9 @@ bool pkgRPMLibPM::Process(vector<const char*> &install,
 #endif
                     
 #if RPM_VERSION >= 0x040300
+#ifdef WITH_SELINUX
    /* Initialize security context patterns for SELinux */
+   cout << "selinux enabled" << endl;
    if (!(tsFlags & RPMTRANS_FLAG_NOCONTEXTS)) {
       rpmsx sx = rpmtsREContext(TS);
       if (sx == NULL) {
@@ -806,6 +808,7 @@ bool pkgRPMLibPM::Process(vector<const char*> &install,
       }
       sx = rpmsxFree(sx);
    }
+#endif
 #endif
 
    if (_config->FindB("RPM::OldPackage", true) || !upgrade.empty()) {