- add allow-duplicated lua script to upgrade slot + relevant synaptic slots
authorpmatilai <pmatilai>
Thu, 25 May 2006 10:26:20 +0000 (10:26 +0000)
committerpmatilai <pmatilai>
Thu, 25 May 2006 10:26:20 +0000 (10:26 +0000)
  (patch from VineLinux)

contrib/allow-duplicated/allow-duplicated.conf
contrib/allow-duplicated/allow-duplicated.lua

index 36b81a2..eb87c5d 100644 (file)
@@ -1,3 +1,5 @@
 Scripts::AptGet::Install::SelectPackage:: "allow-duplicated.lua";
 Scripts::AptGet::DistUpgrade:: "allow-duplicated.lua";
+Scripts::AptGet::Upgrade:: "allow-duplicated.lua";
 Scripts::Synaptic::DistUpgrade:: "allow-duplicated.lua";
+Scripts::Synaptic::Upgrade:: "allow-duplicated.lua";
index c259128..9d9dcf2 100644 (file)
@@ -55,7 +55,9 @@ if script_slot == "Scripts::AptGet::Install::SelectPackage" then
 end
 
 if script_slot == "Scripts::AptGet::DistUpgrade" or
-   script_slot == "Scripts::Synaptic::DistUpgrade" then
+   script_slot == "Scripts::AptGet::Upgrade" or
+   script_slot == "Scripts::Synaptic::DistUpgrade" or
+   script_slot == "Scripts::Synaptic::Upgrade" then
     -- Automatically install newer versions of all packages which
     -- are registered in the Allow-Duplicated scheme and are matched
     -- by the regular expressions in RPM::Allow-Duplicated-Upgrade.