apt.git
15 years ago- force cache rebuild for each run on rpm >= 4.4.4 for runtime dependencies :-/
pmatilai [Mon, 6 Feb 2006 23:16:20 +0000 (23:16 +0000)]
- force cache rebuild for each run on rpm >= 4.4.4 for runtime dependencies :-/

15 years ago- basic implementation of runtime access() dependencies
pmatilai [Mon, 6 Feb 2006 22:43:39 +0000 (22:43 +0000)]
- basic implementation of runtime access() dependencies

15 years ago- implement some rpm >= 4.4.4 runtime probe dependencies
pmatilai [Mon, 6 Feb 2006 21:45:49 +0000 (21:45 +0000)]
- implement some rpm >= 4.4.4 runtime probe dependencies
- add stubs for the rest

15 years ago- prepare for lorg2 apt-0.5.15lorg2
pmatilai [Mon, 6 Feb 2006 19:14:02 +0000 (19:14 +0000)]
- prepare for lorg2

15 years ago- bump version
pmatilai [Mon, 6 Feb 2006 19:12:19 +0000 (19:12 +0000)]
- bump version

15 years ago- add support for yum-style distroverpkg package whose version can be
pmatilai [Mon, 6 Feb 2006 19:11:06 +0000 (19:11 +0000)]
- add support for yum-style distroverpkg package whose version can be
  read from rpmdb (or overwritten with config) and new variable substitution
  $(VERSION) -> distrover in sources.list

15 years ago- move the multilib-stuff to where it belongs to
pmatilai [Mon, 6 Feb 2006 17:21:43 +0000 (17:21 +0000)]
- move the multilib-stuff to where it belongs to

15 years ago- handle the rest of multilib systems .. at least in theory
pmatilai [Wed, 1 Feb 2006 18:58:54 +0000 (18:58 +0000)]
- handle the rest of multilib systems .. at least in theory

15 years ago- a bit more generic compatarch stuff for multilib
pmatilai [Tue, 31 Jan 2006 20:05:14 +0000 (20:05 +0000)]
- a bit more generic compatarch stuff for multilib

15 years ago- remove unused code
pmatilai [Tue, 31 Jan 2006 17:54:02 +0000 (17:54 +0000)]
- remove unused code

15 years ago- much simpler multilib handling by renaming only non-native packages
pmatilai [Tue, 31 Jan 2006 16:25:36 +0000 (16:25 +0000)]
- much simpler multilib handling by renaming only non-native packages

15 years ago- back to multilibbing only rpmdb packages, for repos its way too wacky
pmatilai [Tue, 17 Jan 2006 19:44:49 +0000 (19:44 +0000)]
- back to multilibbing only rpmdb packages, for repos its way too wacky

15 years ago- apply Progeny's redir and authentication patch
pmatilai [Tue, 17 Jan 2006 18:42:37 +0000 (18:42 +0000)]
- apply Progeny's redir and authentication patch

15 years ago- virtual packages can have candidate versions
pmatilai [Tue, 17 Jan 2006 18:41:29 +0000 (18:41 +0000)]
- virtual packages can have candidate versions

15 years ago- thinko in suggests-support
pmatilai [Tue, 17 Jan 2006 02:50:08 +0000 (02:50 +0000)]
- thinko in suggests-support

15 years ago- oops, wrong multilib patch applied, previous only multilibs installed pkgs
pmatilai [Tue, 17 Jan 2006 01:25:18 +0000 (01:25 +0000)]
- oops, wrong multilib patch applied, previous only multilibs installed pkgs

15 years ago- use @ as arch separator instead of .
pmatilai [Tue, 17 Jan 2006 01:05:13 +0000 (01:05 +0000)]
- use @ as arch separator instead of .

15 years ago- initial multilib support (only packages in the same repository are considered)
pmatilai [Tue, 17 Jan 2006 00:31:19 +0000 (00:31 +0000)]
- initial multilib support (only packages in the same repository are considered)

15 years ago- libtoolize -c -f && autoreconf
pmatilai [Tue, 17 Jan 2006 00:04:24 +0000 (00:04 +0000)]
- libtoolize -c -f && autoreconf

15 years ago- autoreconf, so this stuff builds sanely on fc4..
pmatilai [Tue, 17 Jan 2006 00:01:33 +0000 (00:01 +0000)]
- autoreconf, so this stuff builds sanely on fc4..

15 years ago- initial support for enhances/suggests in rpm >= 4.4.3
pmatilai [Mon, 16 Jan 2006 23:56:03 +0000 (23:56 +0000)]
- initial support for enhances/suggests in rpm >= 4.4.3

15 years ago- negative pin on a package is equal to "any version but this"
pmatilai [Mon, 16 Jan 2006 23:24:59 +0000 (23:24 +0000)]
- negative pin on a package is equal to "any version but this"

15 years ago- initial rpm 4.4.4 support
pmatilai [Mon, 16 Jan 2006 23:22:11 +0000 (23:22 +0000)]
- initial rpm 4.4.4 support

15 years ago- appease aclocal >= 1.8 (Ville Skyttä)
pmatilai [Mon, 16 Jan 2006 23:18:56 +0000 (23:18 +0000)]
- appease aclocal >= 1.8 (Ville Skytt√§)

15 years ago- read-only, not exclusive rpmdb lock for the initial dependency processing
pmatilai [Mon, 16 Jan 2006 23:17:30 +0000 (23:17 +0000)]
- read-only, not exclusive rpmdb lock for the initial dependency processing

15 years ago- more python make issues
pmatilai [Mon, 16 Jan 2006 23:16:46 +0000 (23:16 +0000)]
- more python make issues

15 years ago- Fix some issues in python binding build
pmatilai [Mon, 16 Jan 2006 23:16:18 +0000 (23:16 +0000)]
- Fix some issues in python binding build

15 years ago- change scriptdir to /usr/share/apt
pmatilai [Mon, 16 Jan 2006 23:14:40 +0000 (23:14 +0000)]
- change scriptdir to /usr/share/apt

15 years ago- initial import of revision 374 from cnc
pmatilai [Mon, 16 Jan 2006 23:10:47 +0000 (23:10 +0000)]
- initial import of revision 374 from cnc